3.0.0 (2020-07-31)

Bug Fixes

  • deps: roll back dependency react-query to ^2.5.1 (ad5f47e)
  • deps: update dependency @mdx-js/mdx to ^1.6.1 (ed095e9)
  • deps: update dependency @mdx-js/mdx to ^1.6.10 (4df6da7)
  • deps: update dependency @mdx-js/mdx to ^1.6.11 (61332ff)
  • deps: update dependency @mdx-js/mdx to ^1.6.12 (7e6bdd2)
  • deps: update dependency @mdx-js/mdx to ^1.6.14 (494ff20)
  • deps: update dependency @mdx-js/mdx to ^1.6.15 (82c917f)
  • deps: update dependency @mdx-js/mdx to ^1.6.16 (f5f73b0)
  • deps: update dependency @mdx-js/mdx to ^1.6.3 (b15d71b)
  • deps: update dependency @mdx-js/mdx to ^1.6.4 (f3acd04)
  • deps: update dependency @mdx-js/mdx to ^1.6.5 (d233e08)
  • deps: update dependency @mdx-js/mdx to ^1.6.6 (9eb8e44)
  • deps: update dependency @mdx-js/mdx to ^1.6.7 (1922150)
  • deps: update dependency @mdx-js/mdx to ^1.6.8 (ca3b607)
  • deps: update dependency @mdx-js/mdx to ^1.6.9 (5c99afe)
  • deps: update dependency @socialgouv/react-departements to ^… (#170) (bf48260)
  • deps: update dependency @socialgouv/react-departements to v2 (#167) (29c613d)
  • deps: update dependency @socialgouv/react-departements to v3 (cc9cc27)
  • deps: update dependency axios to ^0.19.2 (92de68d)
  • deps: update dependency date-fns to ^2.11.0 (dd15aa9)
  • deps: update dependency date-fns to ^2.12.0 (c9cb54a)
  • deps: update dependency date-fns to ^2.13.0 (43c49b9)
  • deps: update dependency date-fns to ^2.14.0 (95971a3)
  • deps: update dependency date-fns to v2 (83d690a)
  • deps: update dependency formik to ^2.1.5 (a666912)
  • deps: update dependency formik to v2 (026e93b)
  • deps: update dependency next to ^9.3.0 (#158) (d83d479)
  • deps: update dependency next to ^9.3.1 (94f7667)
  • deps: update dependency next to ^9.3.6 (9c14993)
  • deps: update dependency next to ^9.4.0 (037d96e)
  • deps: update dependency next to ^9.4.1 (8eb0540)
  • deps: update dependency next to ^9.4.2 (7fb1747)
  • deps: update dependency next to ^9.4.3 (06c4602)
  • deps: update dependency next to ^9.4.4 (75cbf77)
  • deps: update dependency next to ^9.5.0 (e26fd1f)
  • deps: update dependency next to ^9.5.1 (9240fff)
  • deps: update dependency raw-loader to ^4.0.1 (0843e05)
  • deps: update dependency raw-loader to v4 (0d6852f)
  • deps: update dependency react-query to ^1.0.23 (a8d2a0a)
  • deps: update dependency react-query to ^1.0.27 (b13ff67)
  • deps: update dependency react-query to ^1.0.28 (12eb4c4)
  • deps: update dependency react-query to ^1.0.29 (02de460)
  • deps: update dependency react-query to ^1.0.31 (1d83605)
  • deps: update dependency react-query to ^1.0.33 (46a859c)
  • deps: update dependency react-query to ^1.0.34 (2656f9d)
  • deps: update dependency react-query to ^1.0.35 (08ff22b)
  • deps: update dependency react-query to ^1.1.1 (93958ed)
  • deps: update dependency react-query to ^1.3.0 (60a1a4a)
  • deps: update dependency react-query to ^1.3.3 (7720421)
  • deps: update dependency react-query to ^1.4.1 (68e56bd)
  • deps: update dependency react-query to ^2.0.3 (ecae712)
  • deps: update dependency react-query to ^2.1.1 (1e47205)
  • deps: update dependency react-query to ^2.2.1 (89da12b)
  • deps: update dependency react-query to ^2.2.3 (3c2a18f)
  • deps: update dependency react-query to ^2.4.0 (4d12dd4)
  • deps: update dependency react-query to ^2.4.1 (5d6c00b)
  • deps: update dependency react-query to ^2.4.10 (f390283)
  • deps: update dependency react-query to ^2.4.11 (a0a0e62)
  • deps: update dependency react-query to ^2.4.12 (ecb0961)
  • deps: update dependency react-query to ^2.4.13 (331dba2)
  • deps: update dependency react-query to ^2.4.15 (de77e4f)
  • deps: update dependency react-query to ^2.4.16 (5524a96)
  • deps: update dependency react-query to ^2.4.17 (6c4b3c6)
  • deps: update dependency react-query to ^2.4.19 (34dcf03)
  • deps: update dependency react-query to ^2.4.2 (c532ba4)
  • deps: update dependency react-query to ^2.4.20 (9b93951)
  • deps: update dependency react-query to ^2.4.21 (c61fa90)
  • deps: update dependency react-query to ^2.4.3 (f615c08)
  • deps: update dependency react-query to ^2.4.4 (1de7c69)
  • deps: update dependency react-query to ^2.4.5 (d23277c)
  • deps: update dependency react-query to ^2.4.6 (a81a810)
  • deps: update dependency react-query to ^2.4.9 (2e68076)
  • deps: update dependency react-query to ^2.5.2 (0543499)
  • deps: update dependency react-query to ^2.5.4 (76604b7)
  • deps: update dependency react-query to ^2.5.5 (a03f3d7)
  • deps: update dependency react-query to ^2.5.6 (84c1fb8)
  • deps: update dependency react-query to ^2.5.9 (766e0d3)
  • deps: update dependency react-query to v2 (946b53e)
  • deps: update dependency react-query to v3 (5df455c)
  • deps: update dependency react-redux to ^7.2.1 (28960dc)
  • deps: update dependency react-select to ^3.1.0 (ef5f5c5)
  • deps: update dependency react-select to v3 (12a52de)
  • deps: update dependency rebass to v4 (ae6c39d)
  • deps: update dependency recharts to ^2.0.0-beta.4 (89c1631)
  • deps: update dependency recharts to ^2.0.0-beta.5 (50b2dcf)
  • deps: update dependency recharts to ^2.0.0-beta.6 (c75570d)
  • deps: update dependency styled-components to ^5.1.0 (92b73cf)
  • deps: update dependency styled-components to ^5.1.1 (cb5fd3d)
  • deps: update dependency url-search-params-polyfill to ^8.1.0 (0d4de6f)
  • deps: update dependency url-search-params-polyfill to v8 (da3cbb2)
  • deps: update react monorepo to ^16.13.1 (87bbcf4)
  • footer: invalid href passed to router (#198) (be984f1)
  • footer: the StyledLinks are already tags (#199) (f75942e)
  • validity check: invalid date format for date-fns (#197) (90e13ee)
  • lint (63f59ee)

Features

  • use kosko-charts:2.0.0 (#361) (849922a)

  • api: use new API to get validity-check (#97) (1f833c1)

  • docker: add VERSION args in the builder image (5695f82)

  • docker: add VERSION args in the builder image (2) (a3d4b45)

  • docker: add VERSION args in the builder image (3) (3fa16f1)

  • faq: faq with mdx and embed react-departements (#95) (984d109)

  • footer: change version format (69930d2)

  • k8s: add ci VERSION in frontend pod env (40b6033)

  • k8s: add ci VERSION in the registered builder image (2f8a328)

  • k8s: add ci VERSION in the registered frontend image (09e8847)

  • k8s: use new wif.ds-aggregator api url (#177) (968cc1d)

  • k8s: use new work-in-france-backoffice api url (#345) (4f149eb)

  • layout: add version and link to github in the footer (93c43b0)

  • stats: add Haute-Savoie (#327) (1197a85)

  • stats: add Pyrénées-atlantiques and Isère (#275) (0880989)

  • add 33,51 (#93) (a4a9fb9)

  • local stats (#154) (1dc18e6)

  • refacto(gitlab)!: migrate wif on azure (#136) (8dbe6d1), closes #136

BREAKING CHANGES